Topic: Compilation issue

Hello, I got a new computer using mageia 1.
I have tried to install the mandriva 2010.1 rpm, the install failed, because libpython2.6.so.1.0()(64bit) is not installed. It is the libpython2.7.so.1.0 which is available.
I also tried the fedora 15 rpm, this time it is numpy which is missing (but it is installed).
I tried to compile the source, in the folder
~/mMass/mspy/plot I did:
python setup.py build
Here are all the messages I get:

running build
running build_ext
building 'calculations' extension
gcc -pthread -fno-strict-aliasing -O2 -g -pipe -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -DNDEBUG -O2 -g -pipe -Wformat -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -g -fPIC -I/usr/lib64/python2.7/site-packages/numpy/core/include/numpy -I/usr/include -I/usr/include/python2.7 -c calculations.c -o build/temp.linux-x86_64-2.7/calculations.o
calculations.c: In function ‘calculations_scaleAndShift’:
calculations.c:37:11: attention : assignment from incompatible pointer type
calculations.c: In function ‘calculations_filterPoints’:
calculations.c:146:11: attention : assignment from incompatible pointer type
gcc -pthread -shared -Wl,--as-needed -Wl,--no-undefined -Wl,-z,relro -Wl,-O1 -Wl,--build-id -Wl,--enable-new-dtags build/temp.linux-x86_64-2.7/calculations.o -L/usr/lib64 -lpython2.7 -o build/lib.linux-x86_64-2.7/calculations.so
build/temp.linux-x86_64-2.7/calculations.o: In function `calculations_scaleAndShift':
/usr/local/logiciels/mMass/mspy/plot/calculations.c:44: undefined reference to `round'
/usr/local/logiciels/mMass/mspy/plot/calculations.c:45: undefined reference to `round'
collect2: ld a retourné 1 code d'état d'exécution
error: command 'gcc' failed with exit status 1

Can you help me to install mMass please.
Thank you a lot.


Re: Compilation issue

You have to add the math library to the linker flags.
(I don't know why it is missing on Mageia (Debian use it out of the box))

To change the linker flags replace line 27 in mspy/plot/setup.py

include_dirs=[numpyInclude, pythonInclude]


include_dirs=[numpyInclude, pythonInclude],




Re: Compilation issue

Thank you very much, it is working fine now.
Sorry for the late answer I was quite busy this time.
I will start to explore this version soon.