Topic: Poor resolution when exporting in pdf

Sorry to bother you again.
I used mMass on a fedora 15, and on a Mandriva 2010.1 computer
In both case when I tried to print a pdf file of a zoomed spectra the pdf obtain is really ugly, the line are not smooth at all, and the peaks label are too big.
I can provide an example if it is needed.

Is there any option I should used to print a pdf in Hight resolution. (I would like to get a vectorial image)

Thank you a lot for this software.


Re: Poor resolution when exporting in pdf

could you please provide a link to the sample PDF? I'll check it.



Re: Poor resolution when exporting in pdf

Thank you to take care of my problem,
I used print, then print to file.
The post-script can be downloaded there

I then used ps2pdf to convert it, the pdf is as strange as the post-script (as expected)

I also installed cups-pdf printer, the result is really similar.


Re: Poor resolution when exporting in pdf

..not really nice :-) Well, it strongly depends on the paper size and printer resolution. From those two factors, font scaling, line thickness and spectrum resolution are calculated. You can tweak the font size by setting smaller font size in mMass's "Canvas Preferences". For the spectrum resolution, close mMass, locate the config.xml file and edit following line:

<param name="printQuality" value="5" type="int" />

Use a lower number for the "value" parameter.

Best wishes,


Re: Poor resolution when exporting in pdf

Thank you very much it is working much better now.
I set the printQuality" value to 1.

A small trick for those who like to use vector image in their odt documents (libreoffice, openoffice, koffice ...) .
The import of pdf file is not always working very well. Here the steps I used to import spectrum in my document:

get a post-script, using print to file.
Then open it with inkscape, and save it as pdf (the odg format is not working very well with at least libreoffice).
this pdf can now be opened with libreoffice.

nota: the pdf obtained with ps2pdf program is not very well imported in libreoffice.   

Thank you for your useful and very fast answer.